aboutsummaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <ymherklotz@gmail.com>2017-12-25 12:27:32 +0000
committerYann Herklotz <ymherklotz@gmail.com>2017-12-25 12:27:32 +0000
commit022a4bdd81332ce67d799be6a06afb42ae45ac2e (patch)
tree52aab4ac82cd99d49a94eff8734ec904e0adde54 /examples/CMakeLists.txt
parent16915d86d4b866c1fcce7523b0d34e8343ff52fc (diff)
downloadYAGE-022a4bdd81332ce67d799be6a06afb42ae45ac2e.tar.gz
YAGE-022a4bdd81332ce67d799be6a06afb42ae45ac2e.zip
[Build] Added examples and improved build for them.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 16b20795..a75f6528 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,2 +1,10 @@
-add_executable(simplegame simplegame/main.cpp)
-target_link_libraries(simplegame yage)
+function(make_example name)
+
+ file(GLOB SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${name}/*.cpp)
+ add_executable(${name} ${SOURCES})
+ target_link_libraries(${name} yage)
+
+endfunction(make_test)
+
+make_example(simplegame)
+make_example(shooter)