aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <ymherklotz@gmail.com>2017-09-05 19:41:45 +0100
committerYann Herklotz <ymherklotz@gmail.com>2017-09-05 19:41:45 +0100
commit268cac0f0f5812149a4b4a0d894a100d711a493c (patch)
treecc6df6a0de2217ba177a735cb8fa116bfcdb5237 /lib/CMakeLists.txt
parent81b2d1591d348ee7972d174a2ba2dee8dc7cea96 (diff)
downloadYAGE-268cac0f0f5812149a4b4a0d894a100d711a493c.tar.gz
YAGE-268cac0f0f5812149a4b4a0d894a100d711a493c.zip
Travis CI testing
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 35eca5a5..16555dc0 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -11,7 +11,7 @@ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
# Add googletest directly to our build. This defines
# the gtest and gtest_main targets.
-add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/googletest/)
+add_subdirectory("${CMAKE_CURRENT_SOURCE_DIR}/googletest")
# The gtest/gtest_main targets carry header search path
# dependencies automatically when using CMake 2.8.11 or
@@ -20,4 +20,8 @@ if (CMAKE_VERSION VERSION_LESS 2.8.11)
include_directories("${gtest_SOURCE_DIR}/include")
endif()
-add_subdirectory("${CMAKE_CURRENT_SOURCE_DIR}/yajl")
+# include headers for rapidjson, no need to build it
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}/rapidjson/include")
+
+# include header only rapidxml library
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}/rapidxml")