aboutsummaryrefslogtreecommitdiffstats
path: root/yage/CMakeLists.txt
diff options
context:
space:
mode:
authorTravisBot <>2017-09-21 23:32:46 +0000
committerTravisBot <>2017-09-21 23:32:46 +0000
commit1a8ec165031af3b860028ef1b360acc8e7baf9e6 (patch)
treeb9d2e956005b4de847417baf4a66ab3f028f1bc1 /yage/CMakeLists.txt
parentf5ecbc445977654e84120b3b02a9fe5d86dae5c8 (diff)
downloadYAGE-1a8ec165031af3b860028ef1b360acc8e7baf9e6.tar.gz
YAGE-1a8ec165031af3b860028ef1b360acc8e7baf9e6.zip
Rebuilding documentation
Diffstat (limited to 'yage/CMakeLists.txt')
-rw-r--r--yage/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/yage/CMakeLists.txt b/yage/CMakeLists.txt
new file mode 100644
index 00000000..e9d4071b
--- /dev/null
+++ b/yage/CMakeLists.txt
@@ -0,0 +1,30 @@
+cmake_policy(SET CMP0048 NEW)
+
+project(yage
+ VERSION 0.1.1.0
+ LANGUAGES CXX)
+
+include(base/CMakeLists.txt)
+include(physics/CMakeLists.txt)
+include(math/CMakeLists.txt)
+
+set(YAGE_SOURCES
+ yage.cpp
+ ${YAGE_BASE_SOURCES}
+ ${YAGE_PHYSICS_SOURCES}
+ ${YAGE_MATH_SOURCES})
+
+set(${PROJECT_NAME}_DIR
+ ${PROJECT_SOURCE_DIR})
+
+add_library(${PROJECT_NAME}
+ ${YAGE_SOURCES})
+
+target_include_directories(${PROJECT_NAME}
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
+ ${OPENGL_INCLUDE_DIR})
+
+target_link_libraries(${PROJECT_NAME}
+ ${OPENGL_gl_LIBRARY}
+ glfw
+ glad)