aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt24
1 files changed, 13 insertions, 11 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 3fc37c0e..0f07326f 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -5,19 +5,21 @@
# See file LICENSE for more details
# ----------------------------------------------------------------------------
-# Initializing google test
-# prevents overriding the parent project's compiler/linter settings on windows
-set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
+if(${ENABLE_TESTING})
+ # Initializing google test
+ # prevents overriding the parent project's compiler/linter settings on windows
+ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-# Add googletest directly to our build. This defines
-# the gtest and gtest_main targets.
-add_subdirectory("${CMAKE_CURRENT_SOURCE_DIR}/googletest")
+ # Add googletest directly to our build. This defines
+ # the gtest and gtest_main targets.
+ add_subdirectory("${CMAKE_CURRENT_SOURCE_DIR}/googletest")
-# The gtest/gtest_main targets carry header search path
-# dependencies automatically when using CMake 2.8.11 or
-# later. Otherwise we have to add them here ourselves.
-if (CMAKE_VERSION VERSION_LESS 2.8.11)
- include_directories("${gtest_SOURCE_DIR}/include")
+ # The gtest/gtest_main targets carry header search path
+ # dependencies automatically when using CMake 2.8.11 or
+ # later. Otherwise we have to add them here ourselves.
+ if (CMAKE_VERSION VERSION_LESS 2.8.11)
+ include_directories("${gtest_SOURCE_DIR}/include")
+ endif()
endif()
# include headers for rapidjson, no need to build it