aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index b004643..8308389 100644
--- a/default.nix
+++ b/default.nix
@@ -1,5 +1,4 @@
-with import <nixpkgs> {};
-
+with import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/269fc4ddb896c1c5994eb4bb8c750ec18cb3db82.tar.gz") {};
let
ncoq = coq_8_12;
ncoqPackages = coqPackages_8_12;
@@ -28,7 +27,7 @@ stdenv.mkDerivation {
name = "vericert";
src = ./.;
- buildInputs = [ ncoq dune gcc
+ buildInputs = [ ncoq dune_2 gcc
ocaml ocamlPackages.findlib ocamlPackages.menhir
ocamlPackages.ocamlgraph
];