aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..563797f
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,33 @@
+{
+ description = "Vericert dependencies";
+
+ inputs = { nixpkgs.url = "github:nixos/nixpkgs"; };
+
+ outputs = { self, nixpkgs }:
+ let
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ ncoq = pkgs.coq_8_14;
+ ncoqPackages = pkgs.coqPackages_8_14;
+ in {
+ devShell.x86_64-linux = pkgs.mkShell {
+ buildInputs = with pkgs;
+ [ ncoq
+ dune_2
+ gcc
+ ncoq.ocaml
+ ncoq.ocamlPackages.findlib
+ ncoq.ocamlPackages.menhir
+ ncoq.ocamlPackages.ocamlgraph
+ ncoq.ocamlPackages.menhirLib
+
+ ncoq.ocamlPackages.ocp-indent
+ ncoq.ocamlPackages.utop
+
+ ncoqPackages.serapi
+ python3
+ python3Packages.alectryon
+ python3Packages.sphinx_rtd_theme
+ ];
+ };
+ };
+}