aboutsummaryrefslogtreecommitdiffstats
path: root/nix/hedgehog-fn.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hedgehog-fn.nix')
-rw-r--r--nix/hedgehog-fn.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nix/hedgehog-fn.nix b/nix/hedgehog-fn.nix
new file mode 100644
index 0000000..0bf9279
--- /dev/null
+++ b/nix/hedgehog-fn.nix
@@ -0,0 +1,17 @@
+{ mkDerivation, base, contravariant, hedgehog, stdenv, transformers
+}:
+mkDerivation {
+ pname = "hedgehog-fn";
+ version = "0.6";
+ sha256 = "fb02b67fba97e24c226feba010d2b308934c54e20a0723b6ea7e4eb199f02176";
+ revision = "1";
+ editedCabalFile = "19v7amg8l6s1gadnya8nxkcbi0vd3wqc7h6gvqvs099qaqm7zbb1";
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ base contravariant hedgehog transformers
+ ];
+ homepage = "https://github.com/qfpl/hedgehog-fn";
+ description = "Function generation for `hedgehog`";
+ license = stdenv.lib.licenses.bsd3;
+}