summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2022-10-06 22:38:41 +0100
committerYann Herklotz <git@yannherklotz.com>2022-10-06 22:38:41 +0100
commit5f43e2751ee2e07b0d5f7fdd12a3d2eb1ad2c7c5 (patch)
treea4f04d5b7189895d45eeec4a364651f6e19d8622 /default.nix
downloadpadicted-5f43e2751ee2e07b0d5f7fdd12a3d2eb1ad2c7c5.tar.gz
padicted-5f43e2751ee2e07b0d5f7fdd12a3d2eb1ad2c7c5.zip
Add initial filesmain
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..0cec7d2
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,16 @@
+with import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/269fc4ddb896c1c5994eb4bb8c750ec18cb3db82.tar.gz") {};
+let
+ ncoq = coq_8_12;
+ ncoqPackages = coqPackages_8_12;
+in
+stdenv.mkDerivation {
+ name = "padicted";
+ src = ./.;
+
+ buildInputs = [ ncoq dune_2 gcc
+ ocaml ocamlPackages.findlib ocamlPackages.menhir
+ ocamlPackages.ocamlgraph
+ ];
+
+ enableParallelBuilding = true;
+}