aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <ymherklotz@gmail.com>2017-12-25 13:58:25 +0000
committerYann Herklotz <ymherklotz@gmail.com>2017-12-25 13:58:25 +0000
commit2982430fc0021e72699e45a8b24390bf7ac1f05a (patch)
tree33a26d0cd3babccab15b07cd343808201e53d90e /CMakeLists.txt
parent022a4bdd81332ce67d799be6a06afb42ae45ac2e (diff)
downloadYAGE-2982430fc0021e72699e45a8b24390bf7ac1f05a.tar.gz
YAGE-2982430fc0021e72699e45a8b24390bf7ac1f05a.zip
[Build] Added warning all flag to cmake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2ec7120..1906ce31 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,9 @@ option(YAGE_BUILD_DOCS "Build documentation using Doxygen" ON)
# set standard
set(CMAKE_CXX_STANDARD 14)
+# adding more warnings to cmake
+set(CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS} "-Wall")
+
# find other libraries from source
set(EXTERNAL_DIR ${CMAKE_CURRENT_SOURCE_DIR}/external)