aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <ymherklotz@gmail.com>2017-08-23 20:33:34 +0100
committerYann Herklotz <ymherklotz@gmail.com>2017-08-23 20:33:34 +0100
commit56b5466f014d9f7c3662544713bd53670cd8e32f (patch)
tree479658b1424c53d3e1ceaadb16b095bb34531520 /CMakeLists.txt
parent34f910351863163438c419dd07045f1442321293 (diff)
downloadYAGE-56b5466f014d9f7c3662544713bd53670cd8e32f.tar.gz
YAGE-56b5466f014d9f7c3662544713bd53670cd8e32f.zip
Applied modernize rules and fixed build.
Applied clang-tidy modernize rules and fixed the CMakeLists.txt file so that it also linked against the SDL2 library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f084702c..b92ec79a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,16 +67,16 @@ endif()
# find libraries
find_package(OpenGL REQUIRED)
find_package(GLEW REQUIRED)
+include(FindPkgConfig)
+pkg_search_module(SDL2 REQUIRED sdl2)
# set include directory
-include_directories(${YAGE_INCLUDE_DIR}
- ${YAGE_INCLUDE_DIR}/Physics/
- ${YAGE_INCLUDE_DIR}/Math/)
+include_directories(${YAGE_INCLUDE_DIR})
# make it a static library
add_library(${PROJECT_NAME} ${YAGE_SOURCES})
-set(YAGE_LIB_DEP_L "yage;${OPENGL_LIBRARIES};${GLEW_LIBRARIES};${SDL2_LIBRAIRES}")
+set(YAGE_LIB_DEP_L "yage;${OPENGL_LIBRARIES};${GLEW_LIBRARIES};${SDL2_LIBRARIES}")
message("${YAGE_LIB_DEP_L}")