aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <ymherklotz@gmail.com>2017-08-24 00:25:31 +0100
committerGitHub <noreply@github.com>2017-08-24 00:25:31 +0100
commita326354ea6fccf76665a4212bf14daeba0f52ec8 (patch)
tree18cd2deb0c30b38d8ca7c5305735d2323259e020 /CMakeLists.txt
parent0a49874288f92c120d7e165550eb6dbbe1ef7307 (diff)
parent5403490b941f7c031bf1aafdb91b1098f69edbf2 (diff)
downloadYAGE-a326354ea6fccf76665a4212bf14daeba0f52ec8.tar.gz
YAGE-a326354ea6fccf76665a4212bf14daeba0f52ec8.zip
Merge pull request #3 from ymherklotz/developv0.1.0
Merge develop to master
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f084702c..b92ec79a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,16 +67,16 @@ endif()
# find libraries
find_package(OpenGL REQUIRED)
find_package(GLEW REQUIRED)
+include(FindPkgConfig)
+pkg_search_module(SDL2 REQUIRED sdl2)
# set include directory
-include_directories(${YAGE_INCLUDE_DIR}
- ${YAGE_INCLUDE_DIR}/Physics/
- ${YAGE_INCLUDE_DIR}/Math/)
+include_directories(${YAGE_INCLUDE_DIR})
# make it a static library
add_library(${PROJECT_NAME} ${YAGE_SOURCES})
-set(YAGE_LIB_DEP_L "yage;${OPENGL_LIBRARIES};${GLEW_LIBRARIES};${SDL2_LIBRAIRES}")
+set(YAGE_LIB_DEP_L "yage;${OPENGL_LIBRARIES};${GLEW_LIBRARIES};${SDL2_LIBRARIES}")
message("${YAGE_LIB_DEP_L}")