aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <ymherklotz@gmail.com>2017-12-08 01:23:27 +0000
committerYann Herklotz <ymherklotz@gmail.com>2017-12-08 01:23:27 +0000
commite6215e764bc149497ab5772d9ea136809d898993 (patch)
treebe10db001a2d4eedd611c7db2c5cf7907f55250c /CMakeLists.txt
parent4738752fd7633f68911f97aeda9954ee87b5ce6e (diff)
downloadYAGE-e6215e764bc149497ab5772d9ea136809d898993.tar.gz
YAGE-e6215e764bc149497ab5772d9ea136809d898993.zip
Improving api
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5e13ab4..08b9ec36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,10 @@ project(yage
VERSION 0.1.1.0
LANGUAGES CXX)
+if(NOT DEFINED UNIT_TESTS)
+ set(UNIT_TESTS 0)
+endif()
+
# set standard
set(CMAKE_CXX_STANDARD 14)
@@ -23,7 +27,7 @@ find_package(OpenGL REQUIRED)
include(${CMAKE_CURRENT_SOURCE_DIR}/lib/CMakeLists.txt)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/yage)
-if($ENV{UNIT_TESTS})
+if(UNIT_TESTS)
add_executable(simplegame tests/simplegame.cpp)
target_link_libraries(simplegame yage)