aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 3 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c56bd2f3..cc3f12ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,20 +16,15 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
# find libraries
find_package(OpenGL REQUIRED)
-find_package(GLEW REQUIRED)
-
-# todo: change this to find_package
-include(FindPkgConfig)
-pkg_search_module(SDL2 REQUIRED sdl2)
# adding libraries
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/yage)
-if(${ENABLE_TESTING})
+if($ENV{UNIT_TESTS})
# enable tests
enable_testing()
- set(SIMULATION_RUNS 10000)
+ set(SIMULATION_RUNS 1000)
function(make_test test_name cycles)
add_executable(${test_name} ${YAGE_TEST_DIR}/${test_name}.cpp)
@@ -39,7 +34,7 @@ if(${ENABLE_TESTING})
add_test(NAME ${test_name} COMMAND ${test_name} --gtest_repeat=${cycles} --gtest_break_on_failure)
endfunction(make_test)
- make_test(yagetest ${SIMULATION_RUNS})
+ make_test(yagetest 1)
make_test(matrixtest ${SIMULATION_RUNS})
make_test(particlebodytest ${SIMULATION_RUNS})
make_test(windowtest ${SIMULATION_RUNS})