aboutsummaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2022-03-15 11:26:34 +0000
committerYann Herklotz <git@yannherklotz.com>2022-03-15 11:26:34 +0000
commit77c74349dc7a10563755eda86a4682d14bfcca49 (patch)
tree7976adf337edcde75551acf2e4fb401c4bd66e50 /shell.nix
parentcf44e166a956bb7a00f9185291f02c54d213be0f (diff)
downloadchoc-77c74349dc7a10563755eda86a4682d14bfcca49.tar.gz
choc-77c74349dc7a10563755eda86a4682d14bfcca49.zip
Add explicit shell.nix file
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..ea3de9b
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,8 @@
+with (import <nixpkgs> {});
+{ ghc ? haskell.compiler.ghc8107 }:
+
+haskell.lib.buildStackProject {
+ inherit ghc;
+ name = "choc-env";
+ buildInputs = [ pkgs.haskell-language-server ];
+}