aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2022-03-03 18:32:44 +0000
committerYann Herklotz <git@yannherklotz.com>2022-03-03 18:32:44 +0000
commit63d06d167193107fab60db9552dd8ea7c985af7c (patch)
tree788dfba92ecce2c18051170556c67f7abddc46bf /default.nix
parentf7401188640f8f6726b933e0421400419b62c9b2 (diff)
downloadbiteq-63d06d167193107fab60db9552dd8ea7c985af7c.tar.gz
biteq-63d06d167193107fab60db9552dd8ea7c985af7c.zip
Add initial development files
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..208db0a
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,45 @@
+with import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/00197eff36bb8f7dd7f53a59f730e1fd8e11b1f4.tar.gz") {};
+let
+ ncoq = coq_8_14;
+ ncoqPackages = coqPackages_8_14;
+ bbv = ncoqPackages.callPackage
+ ( { coq, stdenv, fetchFromGithub, mkCoqDerivation }:
+ mkCoqDerivation {
+ pname = "bbv";
+ owner = "ymherklotz";
+
+ defaultVersion = "1.0-dev";
+
+ src = fetchFromGitHub {
+ owner = "mit-plv";
+ repo = "bbv";
+ rev = "d5ab9c04db85eb85688816dc687d118000a65736";
+ sha256 = "0qlgkzwrg80j50md9s3fbnq62xc7fx1cb9f3y8iz714824ihkhbj";
+ };
+
+ buildInputs = [ ];
+ propagatedBuildInputs = [ coq ];
+ enableParallelBuilding = true;
+
+ outputs = [ "out" ];
+
+ meta = with lib; {
+ description = "Bedrock Bit Vector Library";
+ homepage = "https://github.com/mit-plv/bbv";
+ license = licenses.mit;
+ platforms = [ "x86_64-linux" "x86_64-darwin" ];
+ maintainers = [ ];
+ };
+ } ) { } ;
+in
+ncoqPackages.mkCoqDerivation {
+ pname = "biteq";
+ owner = "ymherklotz";
+ defaultVersion = "0.1.0";
+
+ src = ./.;
+
+ buildInputs = [ ncoq bbv ];
+
+ enableParallelBuilding = true;
+}