aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2022-03-04 11:01:13 +0000
committerYann Herklotz <git@yannherklotz.com>2022-03-04 11:01:13 +0000
commit7548c4c4baffdbb07b1edc59b1df2483506a1476 (patch)
tree4ecf9048461c582ed5ccf188097cef82981f2494 /default.nix
parenta698c19127ee861c32e998b14b4ebc7e3a913fe0 (diff)
downloadbiteq-7548c4c4baffdbb07b1edc59b1df2483506a1476.tar.gz
biteq-7548c4c4baffdbb07b1edc59b1df2483506a1476.zip
Remove bbv dependency
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix31
1 files changed, 1 insertions, 30 deletions
diff --git a/default.nix b/default.nix
index 208db0a..e22a74c 100644
--- a/default.nix
+++ b/default.nix
@@ -2,35 +2,6 @@ with import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/00197eff36bb
let
ncoq = coq_8_14;
ncoqPackages = coqPackages_8_14;
- bbv = ncoqPackages.callPackage
- ( { coq, stdenv, fetchFromGithub, mkCoqDerivation }:
- mkCoqDerivation {
- pname = "bbv";
- owner = "ymherklotz";
-
- defaultVersion = "1.0-dev";
-
- src = fetchFromGitHub {
- owner = "mit-plv";
- repo = "bbv";
- rev = "d5ab9c04db85eb85688816dc687d118000a65736";
- sha256 = "0qlgkzwrg80j50md9s3fbnq62xc7fx1cb9f3y8iz714824ihkhbj";
- };
-
- buildInputs = [ ];
- propagatedBuildInputs = [ coq ];
- enableParallelBuilding = true;
-
- outputs = [ "out" ];
-
- meta = with lib; {
- description = "Bedrock Bit Vector Library";
- homepage = "https://github.com/mit-plv/bbv";
- license = licenses.mit;
- platforms = [ "x86_64-linux" "x86_64-darwin" ];
- maintainers = [ ];
- };
- } ) { } ;
in
ncoqPackages.mkCoqDerivation {
pname = "biteq";
@@ -39,7 +10,7 @@ ncoqPackages.mkCoqDerivation {
src = ./.;
- buildInputs = [ ncoq bbv ];
+ buildInputs = [ ncoq ];
enableParallelBuilding = true;
}