aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index e01bcd8..06f2cf9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,13 +6,13 @@
outputs = { self, nixpkgs }:
let vericertDevPackages = pkgs:
let
- ncoq = pkgs.coq_8_14;
- ncoqPackages = pkgs.coqPackages_8_14;
+ ncoq = pkgs.coq_8_17;
+ ncoqPackages = pkgs.coqPackages_8_17;
in
pkgs.mkShell {
buildInputs = with pkgs;
[ ncoq ncoq.ocaml ncoqPackages.serapi dune_3 gcc python3 ]
- ++ (with ncoq.ocamlPackages; [ findlib menhir menhirLib ocamlgraph ocp-indent utop ])
+ ++ (with ncoq.ocamlPackages; [ findlib menhir menhirLib ocamlgraph ocp-indent utop merlin ])
++ (with python3Packages; [ alectryon sphinx_rtd_theme ]);
};
in {