aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2019-07-20 19:44:11 +0100
committerYann Herklotz <git@yannherklotz.com>2019-07-20 19:44:11 +0100
commit003203b33ebac04ee6fc933d444584bb1e81f250 (patch)
tree60b2df5b8f74422c6cc38d8fb789016513b3c3f8 /default.nix
parent7d69341adfef072e46098a5b377a22ab4ce610dd (diff)
downloadverismith-003203b33ebac04ee6fc933d444584bb1e81f250.tar.gz
verismith-003203b33ebac04ee6fc933d444584bb1e81f250.zip
Add nix style build
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..9155713
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,32 @@
+{ mkDerivation, alex, array, base, binary, blaze-html, bytestring
+, Cabal, cabal-doctest, cryptonite, deepseq, DRBG, exceptions, fgl
+, fgl-visualize, filepath, gitrev, hedgehog, hedgehog-fn, lens
+, lifted-base, memory, monad-control, optparse-applicative, parsec
+, prettyprinter, random, recursion-schemes, shakespeare, shelly
+, stdenv, tasty, tasty-hedgehog, tasty-hunit, template-haskell
+, text, time, tomland, transformers, transformers-base
+}:
+mkDerivation {
+ pname = "verifuzz";
+ version = "0.2.0.0";
+ src = ./.;
+ isLibrary = true;
+ isExecutable = true;
+ setupHaskellDepends = [ base Cabal cabal-doctest ];
+ libraryHaskellDepends = [
+ array base binary blaze-html bytestring cryptonite deepseq DRBG
+ exceptions fgl fgl-visualize filepath gitrev hedgehog lens
+ lifted-base memory monad-control optparse-applicative parsec
+ prettyprinter random recursion-schemes shakespeare shelly
+ template-haskell text time tomland transformers transformers-base
+ ];
+ libraryToolDepends = [ alex ];
+ executableHaskellDepends = [ base ];
+ testHaskellDepends = [
+ base fgl hedgehog hedgehog-fn lens parsec shakespeare tasty
+ tasty-hedgehog tasty-hunit text
+ ];
+ homepage = "https://github.com/ymherklotz/VeriFuzz#readme";
+ description = "Random verilog generation and simulator testing";
+ license = stdenv.lib.licenses.bsd3;
+}