aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2019-07-27 00:57:44 +0200
committerYann Herklotz <git@yannherklotz.com>2019-07-27 00:57:44 +0200
commit7e5621f79dfbeb2e5112bef931c4cfc858a2f19e (patch)
tree03677dc06c19f6c188446661a51c158adafc83a8 /default.nix
parent7777952f38b24f26f29c2327296494f32d5f49a9 (diff)
downloadverismith-7e5621f79dfbeb2e5112bef931c4cfc858a2f19e.tar.gz
verismith-7e5621f79dfbeb2e5112bef931c4cfc858a2f19e.zip
Add a benchmark
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/default.nix b/default.nix
index db81294..027ff1b 100644
--- a/default.nix
+++ b/default.nix
@@ -1,11 +1,12 @@
{ mkDerivation, alex, array, base, binary, blaze-html, bytestring
-, Cabal, cabal-doctest, cryptonite, deepseq, DRBG, exceptions, fgl
-, fgl-visualize, filepath, gitrev, hedgehog, hedgehog-fn, lens
-, lifted-base, memory, monad-control, optparse-applicative, parsec
-, prettyprinter, random, recursion-schemes, shakespeare, shelly
-, statistics, stdenv, tasty, tasty-hedgehog, tasty-hunit
-, template-haskell, text, time, tomland, transformers
-, transformers-base, vector
+, Cabal, cabal-doctest, criterion, cryptonite, deepseq, DRBG
+, exceptions, fgl, fgl-visualize, filepath, gitrev, hedgehog
+, hedgehog-fn, lens, lifted-base, memory, monad-control
+, optparse-applicative, parsec, prettyprinter, random
+, recursion-schemes, shakespeare, shelly, statistics, stdenv, tasty
+, tasty-hedgehog, tasty-hunit, template-haskell, text, time
+, tomland, transformers, transformers-base, unordered-containers
+, vector
}:
mkDerivation {
pname = "verifuzz";
@@ -20,7 +21,7 @@ mkDerivation {
lifted-base memory monad-control optparse-applicative parsec
prettyprinter random recursion-schemes shakespeare shelly
statistics template-haskell text time tomland transformers
- transformers-base vector
+ transformers-base unordered-containers vector
];
libraryToolDepends = [ alex ];
executableHaskellDepends = [ base ];
@@ -28,6 +29,7 @@ mkDerivation {
base fgl hedgehog hedgehog-fn lens parsec shakespeare tasty
tasty-hedgehog tasty-hunit text
];
+ benchmarkHaskellDepends = [ base criterion lens ];
homepage = "https://github.com/ymherklotz/VeriFuzz#readme";
description = "Random verilog generation and simulator testing";
license = stdenv.lib.licenses.bsd3;