aboutsummaryrefslogtreecommitdiffstats
path: root/test/CAPI/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2022-09-26 19:08:01 +0100
committerYann Herklotz <git@yannherklotz.com>2022-09-26 19:08:48 +0100
commit0034f32d6d85d7f21cf04c82083860cdb2fe1ddb (patch)
treef37f65190acd6040a262cdb7d2dbf6e2b17556f5 /test/CAPI/CMakeLists.txt
parentb018c1ef00eade87c9efbf48cc2e3466877ea79d (diff)
downloadgsa-mlir-master.tar.gz
gsa-mlir-master.zip
Update MLIR files and include LLVM directoryHEADmaster
Diffstat (limited to 'test/CAPI/CMakeLists.txt')
-rw-r--r--test/CAPI/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/CAPI/CMakeLists.txt b/test/CAPI/CMakeLists.txt
new file mode 100644
index 0000000..eaa6cfc
--- /dev/null
+++ b/test/CAPI/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Here we create a single aggregate shared library with the parts of the CAPI
+# that we want to bundle together. Then we link a simple C executable
+# against it to demonstrate that it does have the fully self contained
+# core MLIR library and our own standalone dialect.
+add_mlir_aggregate(StandaloneCAPITestLib
+ SHARED
+ EMBED_LIBS
+ MLIRCAPIIR
+ # TODO: Remove this in favor of showing fine grained dialect registration
+ # (once available).
+ MLIRCAPIRegisterEverything
+ StandaloneCAPI
+)
+
+add_llvm_executable(standalone-capi-test
+ standalone-capi-test.c
+)
+llvm_update_compile_flags(standalone-capi-test)
+target_link_libraries(standalone-capi-test
+ PRIVATE StandaloneCAPITestLib)