aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2021-09-28 14:50:44 +0100
committerYann Herklotz <git@yannherklotz.com>2021-09-28 14:50:44 +0100
commita08f79d3e01c92859e6b33f602b2be2bb8c52e61 (patch)
treeaa6fe94ea8b3ad841dbda0e354a88f8291d6973d /test/CMakeLists.txt
downloadgsa-mlir-a08f79d3e01c92859e6b33f602b2be2bb8c52e61.tar.gz
gsa-mlir-a08f79d3e01c92859e6b33f602b2be2bb8c52e61.zip
Add initial files
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..29da2b8
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,20 @@
+configure_lit_site_cfg(
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.py.in
+ ${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg.py
+ MAIN_CONFIG
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.cfg.py
+)
+
+set(STANDALONE_TEST_DEPENDS
+ FileCheck count not
+ standalone-opt
+ standalone-translate
+ )
+
+add_lit_testsuite(check-standalone "Running the standalone regression tests"
+ ${CMAKE_CURRENT_BINARY_DIR}
+ DEPENDS ${STANDALONE_TEST_DEPENDS}
+ )
+set_target_properties(check-standalone PROPERTIES FOLDER "Tests")
+
+add_lit_testsuites(STANDALONE ${CMAKE_CURRENT_SOURCE_DIR} DEPENDS ${STANDALONE_TEST_DEPENDS})