aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 29da2b8..d47ba93 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,3 +1,7 @@
+llvm_canonicalize_cmake_booleans(
+ MLIR_ENABLE_BINDINGS_PYTHON
+)
+
configure_lit_site_cfg(
${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.py.in
${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg.py
@@ -7,9 +11,13 @@ configure_lit_site_cfg(
set(STANDALONE_TEST_DEPENDS
FileCheck count not
+ standalone-capi-test
standalone-opt
standalone-translate
)
+if(MLIR_ENABLE_BINDINGS_PYTHON)
+ list(APPEND STANDALONE_TEST_DEPENDS StandalonePythonModules)
+endif()
add_lit_testsuite(check-standalone "Running the standalone regression tests"
${CMAKE_CURRENT_BINARY_DIR}
@@ -18,3 +26,5 @@ add_lit_testsuite(check-standalone "Running the standalone regression tests"
set_target_properties(check-standalone PROPERTIES FOLDER "Tests")
add_lit_testsuites(STANDALONE ${CMAKE_CURRENT_SOURCE_DIR} DEPENDS ${STANDALONE_TEST_DEPENDS})
+
+add_subdirectory(CAPI)