aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorYann Herklotz <git@yannherklotz.com>2021-06-25 12:08:47 +0200
committerYann Herklotz <git@yannherklotz.com>2021-06-25 12:08:47 +0200
commitae0f8943268c42b1985f3b8a0c5bcf2102ed3a87 (patch)
treeeb93f8e5837eca7375b76c71748d5809a435d8c2 /default.nix
downloadzk-visual-ae0f8943268c42b1985f3b8a0c5bcf2102ed3a87.tar.gz
zk-visual-ae0f8943268c42b1985f3b8a0c5bcf2102ed3a87.zip
Add initial files
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..3c0d3a2
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,16 @@
+# This file exists for legacy Nix installs (nix-build & nix-env)
+# https://nixos.wiki/wiki/Flakes#Using_flakes_project_from_a_legacy_Nix
+# You generally do *not* have to modify this ever.
+(import
+ (
+ let
+ lock = builtins.fromJSON (builtins.readFile ./flake.lock);
+ in
+ fetchTarball {
+ url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
+ sha256 = lock.nodes.flake-compat.locked.narHash;
+ }
+ )
+ {
+ src = ./.;
+ }).defaultNix