aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYann Herklotz <ymherklotz@gmail.com>2017-04-02 08:38:10 +0100
committerYann Herklotz <ymherklotz@gmail.com>2017-04-02 08:38:10 +0100
commit6067810ec5afd6476d46c678a1a81ef947b84d6c (patch)
treec0feda3b3e2dd468973a9df138cf26e45f60a35e /CMakeLists.txt
parent2bcac034841473bec27dcadc27a3b434b527abe0 (diff)
downloadArider-6067810ec5afd6476d46c678a1a81ef947b84d6c.tar.gz
Arider-6067810ec5afd6476d46c678a1a81ef947b84d6c.zip
Renamed game library to yage
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8726e5e..3c6171c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,8 +18,8 @@ set(ARIDER_INCLUDE_DIRS ${CMAKE_SOURCE_DIR}/include)
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_SOURCE_DIR}/bin)
-set(ZEDENGINE_INCLUDE_DIRS ${CMAKE_SOURCE_DIR}/zedengine/include/)
-set(ZEDENGINE_LIBRARIES zedengine)
+set(YAGE_INCLUDE_DIRS ${CMAKE_SOURCE_DIR}/yage/include/)
+set(YAGE_LIBRARIES yage)
# setting up configuration header
configure_file (
@@ -39,18 +39,18 @@ find_package(GLEW REQUIRED)
pkg_search_module(SDL2 REQUIRED sdl2)
# add zedengine library
-add_subdirectory(zedengine)
+add_subdirectory(yage)
# adding include directories
include_directories(${ARIDER_INCLUDE_DIRS}
- ${ZEDENGINE_INCLUDE_DIRS}
+ ${YAGE_INCLUDE_DIRS}
${OPENGL_INCLUDE_DIRS}
${GLEW_INCLUDE_DIRS}
${SLD2_INCLUDE_DIRS})
# link libraries
target_link_libraries(${CMAKE_PROJECT_NAME}
- ${ZEDENGINE_LIBRARIES}
+ ${YAGE_LIBRARIES}
${OPENGL_LIBRARIES}
${GLEW_LIBRARIES}
${SDL2_LIBRARIES})