aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5bc84149..aad9ab05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,20 +49,7 @@ set(YAGE_SOURCES
${PROJECT_SOURCE_DIR}/src/texturecache.cpp
${PROJECT_SOURCE_DIR}/src/window.cpp)
-# Initializing google test
-# prevents overriding the parent project's compiler/linter settings on windows
-set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-
-# Add googletest directly to our build. This defines
-# the gtest and gtest_main targets.
-add_subdirectory(${PROJECT_SOURCE_DIR}/googletest)
-
-# The gtest/gtest_main targets carry header search path
-# dependencies automatically when using CMake 2.8.11 or
-# later. Otherwise we have to add them here ourselves.
-if (CMAKE_VERSION VERSION_LESS 2.8.11)
- include_directories("${gtest_SOURCE_DIR}/include")
-endif()
+add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib)
# find libraries
find_package(OpenGL REQUIRED)